Datto SaaS Protection - Partners unable to access the SaaS Protection Status Page within the Datto Partner Portal

Incident Report for Kaseya Inc

Resolved

The SaaS Protection Status Page is functioning normally again.

This issue has been resolved.
Posted Nov 11, 2025 - 14:25 EST

Update

The SaaS Protection Status page is accessible and loading again for Partners.

Our R&D team is continuing to investigate and address the issue further.
Posted Nov 11, 2025 - 13:44 EST

Investigating

We are still receiving reports that the SaaS Protection Status Page is inaccessible for some partners and our R&D team is continuing investigations.
Posted Nov 11, 2025 - 12:32 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 11, 2025 - 12:16 EST

Identified

We are aware of a problem where partners are currently unable to access the SaaS Protection Status Page within the Datto Partner Portal and are receiving a 500 error.

The Kaseya R&D Team has identified the issue and are actively working to resolve it.

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Nov 11, 2025 - 11:50 EST
This incident affected: Datto SaaS Protection (SaaS Protection Console Login, SaaS Protection Client Onboarding).