Our R&D team has completed deployment of the hotfix to all regions and are monitoring for any other issues.
Posted Nov 21, 2025 - 08:00 EST
Monitoring
Our R&D team has started deployment of the hotfix to address this issue and are closely monitoring progress.
Posted Nov 20, 2025 - 15:14 EST
Identified
A hotfix to address the issue has been developed and is being prepared for deployment.
Posted Nov 20, 2025 - 13:41 EST
Investigating
We are aware of a problem where, due to a UI issue, SaaS Protection customers are unable to select older snapshots for export/restore.
The Kaseya R&D Team has identified the issue and are actively working to deploy a hotfix to restore functionality.
In the meantime our Support team has been supplied with a workaround and can assist with recovery of historical snapshots as needed. If you require assistance with this, please create a ticket with our Support team.