VSA 10 - Intermittent issues when users attempt to login and/or navigate the product, and using remote control

Incident Report for Kaseya Inc

Postmortem

Root Cause Analysis – VSA10: Intermittent Server Errors During Navigation and Login Attempts

Summary:
Between November 18, 2025, 11:00 a.m. EST and November 19, 2025, 5:00 a.m. EST, customers in all regions experienced intermittent failures when logging into the VSA 10 Web Application or navigating within the application after logging in.

Root Cause:
The issue was traced to a connectivity problem between a server cluster supporting the VSA 10 application and its backend database. This disruption resulted in a cascade of downstream service degradations, ultimately affecting the VSA 10 application servers that process user requests from both the Web Application and Agents on managed devices.

Resolution:
The affected database servers were rebuilt. Following a required configuration update to redirect traffic to the new database instances, the service was restored to a healthy state and all VSA10 features were fully operational.

Preventative Measures:
To mitigate risk and limit future impact, the following steps are being implemented:

  • Assess Related Dependencies and Services:
    The Kaseya R&D Team will conduct a comprehensive review of all component dependencies, ensuring all connected services are adequately mapped for improved monitoring, alerting, and response.
  • Enhanced Monitoring and Alerting:
    The R&D Team will strengthen monitoring and alerting for critical components, providing continuous visibility and enabling proactive actions to prevent service degradation.
  • Hardening Internal Systems and Dependencies:
    Infrastructure upgrades will be considered to reinforce core system functionality against potential component failures.
  • Enhanced Incident Management and Response:
    Global Kaseya Teams will continue to train on Incident Management playbooks to improve awareness and coordination among internal stakeholders during events.
Posted Nov 24, 2025 - 11:38 EST

Resolved

This incident has been resolved.
Posted Nov 19, 2025 - 09:31 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 19, 2025 - 05:20 EST

Update

The R&D team continues to work on a fix for this issue. The issue is present on the APAC, EU, and US regions at this time.
Posted Nov 18, 2025 - 21:41 EST

Update

The R&D team have identified ways to mitigate the problem. We are still investigating the root cause to develop a permanent fix.
Posted Nov 18, 2025 - 17:31 EST

Update

We are continuing to work on a fix for this issue.
Posted Nov 18, 2025 - 16:50 EST

Update

We are continuing to work on a fix for this issue.
Posted Nov 18, 2025 - 15:45 EST

Update

We are continuing to work on a fix for this issue.
Posted Nov 18, 2025 - 14:28 EST

Identified

The issue has been identified and the R&D and Operations teams are working with our vendor, Cloudflare, to resolve the issue.
Posted Nov 18, 2025 - 13:03 EST

Update

We are continuing to investigate this issue.
Posted Nov 18, 2025 - 12:12 EST

Investigating

We are aware of an intermittent problem where users receive an error when attemtping to login and/or navigate the VSA10 Web Application.

The Kaseya R&D Team is investigating the issue.

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Nov 18, 2025 - 12:09 EST
This incident affected: VSA 10 (APAC, EU, US, US - Andromeda10, EU - Andromeda10).