Endpoint Backup v2 - Assets Can Fail to Display in UniView

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Oct 29, 2025 - 08:59 EDT

Monitoring

A fix has been implemented, and we are currently monitoring the results to ensure stability.
Posted Oct 28, 2025 - 18:18 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 28, 2025 - 11:56 EDT

Investigating

We are aware of a problem where Endpoint Backup v2 assets can fail to display in UniView.



The Kaseya R&D Team is currently investigating the issue and working towards a resolution.



Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Oct 28, 2025 - 11:34 EDT
This incident affected: Endpoint Backup V2 (Agent Registration).