Datto Workplace - AU5 Report Files Not Loading

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Nov 20, 2025 - 08:48 EST

Investigating

We are investigating an issue impacting AU5 partners where some DWP Report Files are not opening in browser or agent. Other regions are not affected.

The Kaseya R&D Team is actively investigating.

Subscribe to the Kaseya Status Page for up to date information at https://status.kaseya.com/
Posted Nov 19, 2025 - 20:19 EST
This incident affected: Datto Workplace (AU5).