Kaseya Quote Manager - v25.19.2 Hotfix Release

Incident Report for Kaseya Inc

Resolved

This release has been validated and all systems are now operational.
Posted Nov 27, 2025 - 18:57 EST

Investigating

We are currently updating all Kaseya Quote Manager systems, a brief downtime period is expected.

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Nov 27, 2025 - 18:46 EST
This incident affected: Kaseya Quote Manager (Web Application).