Datto SaaS Protection - Backup Performance Degradation for services on pod 'use1-saas-p8'

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Oct 27, 2025 - 08:22 EDT

Update

After the configuration changes made yesterday, backup success rates for customers hosted on pod 'use1-saas-p8' have improved.

Our R&D team is continuing to monitor.
Posted Oct 21, 2025 - 13:30 EDT

Monitoring

Configuration changes have been implemented on the pod to address the issue.

Our R&D team is monitoring.
Posted Oct 20, 2025 - 11:21 EDT

Identified

The issue has been identified and the R&D team is working to implement configuration changes on the pod to address it.
Posted Oct 20, 2025 - 10:00 EDT

Investigating

We are aware of a problem where some customers hosted on pod 'use1-saas-p8' are experiencing degraded backup performance for some services.

The Kaseya R&D Team is actively investigating.

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Oct 17, 2025 - 12:21 EDT
This incident affected: Datto SaaS Protection (SaaS Protection Backups).