Datto SaaS Protection - Service disruption for customers hosted on node 'des1-bfyii-2984'

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 08:26 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 17, 2025 - 16:11 EST

Update

We are continuing to work on a fix for this issue.
Posted Nov 15, 2025 - 10:45 EST

Identified

We are aware of a problem where SaaS Protection customers hosted on node ‘des1-bfyii-2984' are unable to access their accounts and experiencing a disruption of their SaaS Protection services.

The Kaseya R&D Team has identified the issue and are working to resolve it.

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Nov 14, 2025 - 13:17 EST
This incident affected: Datto SaaS Protection (SaaS Protection Backups, SaaS Protection Console Login, SaaS Protection Seat Management).