Multiple Products - Impacts from Cloudflare Global Network Issues

Incident Report for Kaseya Inc

Postmortem

On November 18th at 8:30AM EST, our Graphus and download.datto[.]com users experienced a service interruption which caused login and other navigation issues.

The root cause of this service interruption was caused by Cloudflare's global network issues.

As Cloudflare restored their infrastructure, our products recovered. Cloudflare's own RCA can be found here: https://blog.cloudflare.com/18-november-2025-outage/ with more information.

Preventative Measures:
To reduce the likelihood and impact of similar incidents in the future:

The Global Kaseya Teams will continue to be trained and coached on the Incident Management playbooks to ensure that all internal stakeholders are made aware of events as they occur.

Cloudflare has committed to:

  • Hardening ingestion of Cloudflare-generated configuration files in the same way we would for user-generated input
  • Enabling more global kill switches for features
  • Eliminating the ability for core dumps or other error reports to overwhelm system resources
  • Reviewing failure modes for error conditions across all core proxy modules
Posted Nov 20, 2025 - 15:27 EST

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 10:30 EST

Monitoring

Cloudflare have implemented a fix for the issue:
- Graphus Login is restored and working as expected.
- Navigation on downloads.datto[.]com is restored and working as expected.

We are monitoring the fix. For more details please see: https://www.cloudflarestatus.com/incidents/8gmgl950y3h7
Posted Nov 18, 2025 - 10:00 EST

Update

We have observed a CloudFlare outage which is causing these downstream impacts to our Products:

- Graphus users are not able to login and receive an "Internal Server Error" from Cloudflare
- Navigation issues are observed on "downloads.datto.com" but file and image downloads remain fully functional.

CloudFlare has provided an update: They have deployed a fix and are still working to remediate broader impacts.
For more details please see: https://www.cloudflarestatus.com/incidents/8gmgl950y3h7
Posted Nov 18, 2025 - 09:42 EST

Identified

We are aware of a problem where users cannot log into Graphus due to an "Internal Server Error".

This error is caused by a service degradation in CloudFlare, which Graphus relies on.
More information from CloudFlare can be found here: https://www.cloudflarestatus.com/incidents/8gmgl950y3h7

Subscribe to the Kaseya Status Page for up-to-date information on how Graphus is impacted here https://status.kaseya.com/
Posted Nov 18, 2025 - 08:41 EST
This incident affected: downloads.datto.com (https://download.kaseya.com) and Graphus.