Datto Endpoint Backup for PC - Degraded Offsite Capabilities for Cloud Siris use1-dtc-server-66

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Oct 30, 2025 - 10:18 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 30, 2025 - 09:21 EDT

Update

The R&D Team has identified the need to take the server offline to finish the hardware repairs. We estimate the server to be offline for 5 days and during this time backups and restores will not be accessible.

We will continue to provide updates as the repairs progress.
Posted Oct 09, 2025 - 15:03 EDT

Identified

We are aware of an issue where Datto Endpoint Backup for PC users paired with Cloud Siris 'use1-dtc-server-66' may experience degraded performance, which can result in slower-than-average backup and restore speeds.



The Kaseya R&D Team has identified the issue and is working towards a resolution.



Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Oct 09, 2025 - 12:29 EDT
This incident affected: Datto / Unitrends Endpoint Backup for PCs (Backup, Verification, Recovery).