Kaseya Quote Manager - Custom Text on Product Titles in Quotes has disappeared

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.

Please note, the custom text descriptions may still be missing from any affected quotes that have had a new version saved recently. To repopulate the full descriptions, you can edit the quote and restore it to a previous version using the version history tool. Please feel free to contact our Support team if you would like assistance with these steps.
Posted Nov 27, 2025 - 11:44 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 27, 2025 - 10:10 EST

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 27, 2025 - 05:56 EST

Update

Product Management has engaged Engineering regarding this issue.
Posted Nov 27, 2025 - 01:43 EST

Update

We are continuing to investigate this issue.
Posted Nov 26, 2025 - 21:23 EST

Investigating

We are aware of a problem where custom text entered into the product title on quotes that were saved previously are now missing.

The Kaseya R&D Team is actively investigating this issue.

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Nov 26, 2025 - 21:11 EST
This incident affected: Kaseya Quote Manager (Web Application).