Maintenance on node 'gbe2-bfyii-327' has been completed and the node is back online. All customer accounts are accessible and backups are running. Our R&D team is continuing to monitor.
Posted May 01, 2026 - 08:29 EDT
Update
Maintenance is still in progress to address a hardware issue found on node 'gbe2-bfyii-327'. We will continue to provide updates from the team as the maintenance progresses.
Posted Apr 29, 2026 - 10:00 EDT
Update
Maintenance on node 'gbe2-bfyii-327' is still in progress. We will continue to provide updates as they become available.
Posted Apr 27, 2026 - 08:45 EDT
Update
Our R&D team is performing maintenance on node 'gbe2-bfyii-327' over the weekend to repair a hardware issue that was identified. There is still currently no ETA on when services for customers hosted on this node will be fully restored. We will provide more updates from the team as they become available.
Posted Apr 24, 2026 - 15:30 EDT
Identified
Our R&D team is continuing to address this issue.
Posted Apr 24, 2026 - 10:15 EDT
Investigating
We are aware of a problem where customers hosted on node 'gbe2-bfyii-327' are experiencing a disruption to their SaaS Protection services.
The Kaseya R&D Team has identified the issue and are actively working to resolve it.