Datto SaaS Protection - Service disruption for customers hosted on node 'aue1-bfyii-1533'

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Nov 24, 2025 - 13:00 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 24, 2025 - 09:34 EST

Update

We are continuing to investigate this issue.
Posted Nov 24, 2025 - 02:31 EST

Investigating

We are currently aware of a problem where some Datto SaaS Protection customers hosted on node 'aue1-bfyii-1533' are experiencing degraded backup performance for all services.

Subscribe to receive up-to-date notifications on future maintenance periods by visiting https://status.kaseya.com/
Posted Nov 24, 2025 - 02:29 EST