Endpoint Backup/Endpoint Backup for PC - Nodes are reporting inconsistent or failed check‑in activity

Incident Report for Kaseya Inc

Monitoring

We identified the cause of the check-in failures affecting Endpoint Backup for PC and Endpoint Backup nodes.

A fix has been implemented, and we are actively monitoring the results. Recovery is underway and devices may take a short period to re-establish successful communication.

We understand the impact this may have on your operations and appreciate your patience. We will continue monitoring and will provide another update as we confirm full stability.

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Feb 02, 2026 - 20:46 EST

Investigating

We are aware of a problem where Endpoint Backup for PC and Endpoint Backup nodes are currently experiencing check‑in failures and are unable to establish successful communication.



The Kaseya R&D Team is currently investigating the issue and working towards a resolution.



Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Feb 02, 2026 - 16:00 EST
This incident affects: Datto / Unitrends Endpoint Backup (Agent Registration, Backup) and Datto / Unitrends Endpoint Backup for PCs (Agent Registration, Backup, Verification, Recovery).