A fix has been implemented and the 'SaaS Protection Status' page and 'Manage Organizations' page within the Datto Partner Portal are loading normally again.
The R&D team is continuing to closely monitor for any other issues.
Posted Jun 18, 2025 - 12:56 EDT
Investigating
The reported issue persists after the changes that were implemented and is also affecting the functionality of the "Manage Organizations" page for BCDR.
The Kaseya R&D team is continuing to investigate.
Posted Jun 18, 2025 - 11:10 EDT
Monitoring
A fix has been implemented and we are testing the changes.
Posted Jun 18, 2025 - 09:15 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 18, 2025 - 08:40 EDT
Identified
The Kaseya R&D Team has identified the cause of the issues and is working to implement a resolution.
Posted Jun 18, 2025 - 08:23 EDT
Investigating
We are aware of reports regarding Datto SaaS Protection organizations not loading in the Datto Partner Portal.
The Kaseya R&D team is actively investigating the issue.