Datto Workplace/Datto File Protect - US-Based Users Are Unable to Access The Manager Portal and The Team Portal

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Sep 11, 2025 - 15:12 EDT

Investigating

We are aware of a problem where Datto Workplace and Datto File Protection users in the US region can experience an access failure when attempting to log into the Manager Portal and Team Portal.



The Kaseya R&D Team is currently investigating the issue.



Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Sep 11, 2025 - 15:00 EDT
This incident affected: Datto File Protection (US8, US9, US17) and Datto Workplace (US1, US6, US15).