Summary:
Between 2026-04-20 14:15 UTC and 2026-04-20 14:39 UTC, some US and UK customers could not access their BMS portals due to a timeout error.
Root Cause:
An unexpected infrastructure event caused a subset of backend systems supporting the BMS portal to become temporarily unavailable. This resulted in timeout errors for some users in the US and UK while accessing the service.
Incident Timeline:
- Identified: 2026-04-20 14:20 UTC
- Resolved: 2026-04-20 14:39 UTC
- Backfill post to the Status Page: 2026-04-20 15:14 UTC
Preventative Measures:
To reduce the likelihood and impact of similar incidents in the future, we are taking the following steps:
Strengthened Change Management:
- Additional validation steps will be required to confirm maintenance timing and scope before any changes that could affect production systems.
Improved Monitoring and Alerting:
- Expanded monitoring to more quickly detect unexpected system restarts or availability issues.
- Enhanced alerts to ensure faster awareness and response when critical systems are impacted.
Operational Readiness Improvements:
- Updated internal procedures and runbooks to support faster recovery during infrastructure-related incidents.
- Regular reviews of incident response practices to ensure teams are prepared to handle similar scenarios efficiently.