Datto SaaS Protection - Backup performance degradation for SharePoint and Teams services on pod 'des1-saas-p0'

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Feb 15, 2026 - 13:52 EST

Update

After the changes to address the issue were implemented, we are observing improvements in backup success rates for SharePoint and Teams services on pod 'des1-saas-p0'.

The Kaseya R&D team is continuing to monitor.
Posted Feb 13, 2026 - 16:00 EST

Monitoring

The Kaseya R&D team has implemented changes to address the degraded backup performance affecting some SharePoint and Teams services on pod 'des1-saas-p0' and they are monitoring the results.
Posted Feb 13, 2026 - 11:24 EST

Identified

We are aware of a problem where some Datto SaaS Protection customers hosted on pod 'des1-saas-p0' are experiencing degraded backup performance for SharePoint and Teams services.

The Kaseya R&D team has identified the issue and are actively working to resolve it.

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Feb 12, 2026 - 10:18 EST
This incident affected: Datto SaaS Protection (SaaS Protection Backups).