Datto BCDR - Degraded Offsite Performance - server5856

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Feb 20, 2026 - 09:07 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 18, 2026 - 09:52 EST

Investigating

We are aware of a problem where Datto BCDR users paired to server5856 can experience degraded offsite capabilities.

The Kaseya R&D Team is investigating the issue and working towards a resolution.

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Feb 17, 2026 - 17:39 EST
This incident affected: Datto BCDR Devices (Off-Site Recovery).