Error 500 in Datto Partner Portal for Backup & RMM Products.

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Sep 02, 2026 - 06:11 EDT

Update

We are continuing to monitor for any further issues.
Posted Sep 02, 2026 - 04:40 EDT

Monitoring

We are pleased to inform you that the recent service incident experienced by our BCDR AND DRMM partners where users experienced difficulties logging into the Datto Partner Portal has now been successfully resolved. We understand the impact that such problems can have on your business operations, and we sincerely apologize for any inconvenience caused during this time.

Our team has been diligently working to identify the root cause of the problem. Our goal is to not only address the immediate concern but also to minimize the risk of similar incidents in the future. By analyzing the underlying factors, we aim to enhance our systems and processes, ensuring a more robust and reliable experience for all our partners.

Thank you for your patience and understanding. We remain committed to delivering exceptional service and continuous improvement.
Posted Sep 02, 2026 - 03:30 EDT

Investigating

We are aware of an issue where customers are encountering 500 errors while accessing Backup & RMM products within the Datto Partner Portal (DPP).

The Kaseya R&D Team is investigating the issue.

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Sep 02, 2026 - 02:00 EDT
This incident affected: Datto Partner Portal (Status Components).