We are pleased to report that the invoice image display issue affecting some partners utilizing QuickBooks Online has been resolved.
Through thorough investigation and collaboration with Intuit, we identified that the issue was caused by deprecated invoice templates. Testing and positive confirmation from affected partners have shown that updating to the Airy New invoice template resolves the problem.
If you have been impacted and have not yet updated your template, we recommend switching to the Airy New template in QuickBooks Online. If you require further assistance or have additional questions, please get in touch with our Support team by creating a ticket or calling 833-863-2237.
Thank you for your patience while we worked toward a solution. Please subscribe to the Kaseya Status Page for future updates and status information.
Posted Sep 11, 2025 - 15:57 EDT
Monitoring
Our investigation with Intuit has identified that the invoicing templates used within QuickBooks Online may be the cause of the image display issues.
The older templates, such as Airy Classic, Modern, Fresh, Bold, and Friendly, are considered deprecated. Our testing and initial reports from partners show that updating to the Airy New template resolves this issue.
If you need help with the update or have additional questions, please feel free to create a ticket with our Support team or contact them at 833-863-2237.
Posted Aug 25, 2025 - 09:20 EDT
Update
We are continuing to work internally and with Intuit to investigate this issue. The behavior is intermittent, does not affect all partners, and is limited to new invoice notifications.
As a workaround, you can remove invoice images, utilize PSA invoice images, or resend the affected invoices. More information will follow when available. If you need assistance with the workarounds, please create a ticket with our Support team or contact them at 833-863-2237.
We are continuing to work internally and with Intuit to investigate this issue.
Posted Jul 15, 2025 - 09:40 EDT
Investigating
We are aware of reports regarding QuickBooks Online invoice images not displaying as intended. Our team is currently working with Intuit to resolve this issue.
As a workaround, please utilize the PSA invoice image rather than the one provided by QuickBooks Online or remove the invoice images. More information will follow when available. If you need assistance with the workaround, please create a ticket with our Support team or contact them at 833-863-2237.