Datto SaaS Protection - Backup performance degradation for SharePoint and Teams services on pod 'aue1-saas-p0'

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Mar 02, 2026 - 09:21 EST

Monitoring

The Kaseya R&D team have implemented configuration changes on the pod to address the issue.

Sharepoint and Teams success rates are improving and the Kaseya R&D team is actively monitoring.
Posted Feb 27, 2026 - 14:05 EST

Identified

We are aware of a problem where some Datto SaaS Protection customers hosted on pod 'aue1-saas-p0' are currently experiencing degraded backup performance for SharePoint and Teams services.

The Kaseya R&D team has identified the issue and are actively working to resolve it.

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Feb 26, 2026 - 13:09 EST
This incident affected: Datto SaaS Protection (SaaS Protection Backups).