Kaseya Store - Service Disruption

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted May 05, 2025 - 05:10 EDT

Investigating

We are experiencing Service disruption on myportal.kaseya.com (Kaseya Store).

Our team is working to restore functionality at this time.

We apologize for any inconvenience.

- Kaseya Cloud Operations Team
Posted May 05, 2025 - 02:42 EDT
This incident affected: Kaseya Store.