Teams backup success rates have stabilized after the recent changes that were implemented.
The Kaseya R&D team is monitoring.
Posted Jun 18, 2025 - 11:46 EDT
Update
Degraded backup performance for Teams services has again been observed for some customers hosted on the pod.
While the Kaseya R&D team continues to investigate they will be temporarily decreasing the daily Teams backup frequency from 3x per day to 2x per day to allow the service to stabilize.
Posted Jun 10, 2025 - 15:32 EDT
Update
Teams backup success rates have stabilized on the pod.
The Kaseya R&D team is continuing to investigate additional changes to address the issue further.
Posted Jun 09, 2025 - 08:37 EDT
Update
The Kaseya R&D team is actively investigating additional changes to be implemented to address the continued Teams backup performance degradation affecting some customers hosted on the pod.
Posted Jun 06, 2025 - 16:00 EDT
Update
Additional configuration changes have been made on the affected pod to further address the Teams backup performance degradation.
The Kaseya R&D team is monitoring results.
Posted Jun 05, 2025 - 11:22 EDT
Update
Backup success rates for Teams services have improved and our R&D team is continuing to monitor.
Posted Jun 02, 2025 - 16:36 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 02, 2025 - 08:18 EDT
Investigating
We are currently aware of a problem where some Datto SaaS Protection customers hosted on pod 'cae1-saas-p0' are experiencing degraded backup performance for Teams services.