Datto SaaS Protection - SaaS Protection Status Page Is Not Loading Details

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Sep 01, 2026 - 09:27 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 01, 2026 - 08:52 EDT

Investigating

We are aware of a problem where the Datto SaaS Protection Status Page is not loading details for some of our users.

The Kaseya Engineering Team is currently investigating the issue.

Should you need any additional questions or require assistance, please contact our support team at https://helpdesk.kaseya.com/hc/en-gb#/contact

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Sep 01, 2026 - 08:13 EDT
This incident affected: Datto SaaS Protection (SaaS Protection Seat Management, SaaS Protection Client Onboarding).