Autotask - Multiple Regions - Inbound emails are not creating tickets

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.

All inbound emails that occurred during the incident timeframe have been successfully reprocessed.
Posted Jul 29, 2026 - 03:04 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 28, 2026 - 14:06 EDT

Investigating

We are aware of a problem where tickets are not getting created from inbound emails.

The Kaseya Engineering Team is investigating the issue.

Should you need any additional questions or require assistance, please contact our support team at https://helpdesk.kaseya.com/hc/en-gb#/contact

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Jul 28, 2026 - 14:01 EDT
This incident affected: Autotask PSA (Limited Release, America East, America East 2, America East 3, America West, America West 2, America West 3, Australia / New Zealand, Australia / New Zealand 2, Spanish (Español), AT01).