KaseyaOne & Kaseya Store - Issues with payment provider

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Aug 06, 2026 - 12:56 EDT

Identified

Our payment provider for KaseyaOne and Kaseya Store has identified intermittent connectivity issues with our fraud prevention provider that might cause increased authentication declines.

During this time, users may experience intermittent issues related to payment processing in KaseyaOne and Kaseya Store.

Core platform functionality outside of payment services will remain unaffected.

We recommend avoiding payment-related actions during this maintenance window where possible. We will monitor the situation and provide updates if necessary.
Posted Aug 06, 2026 - 09:41 EDT
This incident affected: KaseyaOne and Kaseya Store.