Service Disruption for customers on Kaseya Store Portal
Incident Report for Kaseya Inc
Resolved
This incident has been resolved.
Posted Nov 20, 2024 - 06:08 EST
Update
We are continuing to investigate this issue.
Posted Nov 20, 2024 - 05:01 EST
Investigating
We are currently experiencing an issue with the Kaseya Store Portal (http://myportal.kaseya.com). Users may encounter errors when attempting to log in.
Our team is actively working to identify and resolve the issue as quickly as possible. We sincerely apologize for any inconvenience this may cause.
Thank you for your patience and understanding.

- Kaseya Cloud Operations Team
Posted Nov 20, 2024 - 04:57 EST
This incident affected: Kaseya Store.