Datto SaaS Protection - Backup performance degradation for M365 services on pod 'usw3-saas-p1'

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Jan 16, 2026 - 08:52 EST

Update

Backup success rates for M365 services on the pod are returning to normal and our R&D team is continuing to monitor for any other issues.
Posted Jan 15, 2026 - 14:15 EST

Monitoring

The Kaseya R&D team has implemented changes on the pod to address the issue and are monitoring the results.
Posted Jan 15, 2026 - 13:09 EST

Identified

We are aware of a problem where some Datto SaaS Protection customers hosted on pod 'usw3-saas-p1' may experience degraded backup performance for some M365 services.

The Kaseya R&D team has identified the issue and are actively working toward a resolution.

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Jan 15, 2026 - 11:02 EST
This incident affected: Datto SaaS Protection (SaaS Protection Backups).