Endpoint Backup v2 – Service Interruption

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Nov 04, 2025 - 22:54 EST

Investigating

We’re investigating an issue causing Endpoint Backup v2 assets to appear offline in UniView. Impact includes agent check-ins timing out, agent registration errors, scheduled backups not running, and intermittent failures with backup restore and BMR operations across all regions.

The Kaseya R&D Team is currently investigating this issue.

Subscribe for notifications: https://status.kaseya.com/
Posted Nov 04, 2025 - 17:16 EST
This incident affected: Endpoint Backup V2 (Backup, Agent Registration, Restore).