Service Degradation - DES1 DC

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Jul 23, 2026 - 02:26 EDT

Update

We are continuing to monitor this.
Posted Jul 23, 2026 - 00:30 EDT

Monitoring

Service has been restored. All targets in the DES1 data center are now accessible and fully operational.

Apologies for the inconvenience caused.

- Kaseya Cloud Operations Team.
Posted Jul 23, 2026 - 00:29 EDT

Investigating

We are currently experiencing service disruption in DES1 DC.

Our team is working to restore the functionality on the affected instances at this time.

We apologize for any inconvenience this may cause.

- Kaseya Cloud Operations Team
Posted Jul 23, 2026 - 00:17 EDT
This incident affected: Unitrends Cloud Services (DES01 - Munich, EU).