Datto Endpoint Backup/Datto Endpoint Backup for PC - Backup and Screenshot Completion Failures

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Feb 05, 2026 - 14:45 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 04, 2026 - 14:45 EST

Identified

We are aware of a problem where Endpoint Backup and Endpoint Backup for PC assets may encounter intermittent backup and screenshot failures.



The Kaseya R&D Team has identified the issue and is working towards a resolution.



Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Feb 04, 2026 - 11:23 EST

Update

We are continuing to monitor for any further issues.
Posted Feb 03, 2026 - 18:02 EST

Monitoring

A fix has been implemented to address intermittent backup failures impacting some Endpoint Backup and Endpoint Backup for PC assets.

We are monitoring to confirm backup operations continue to stabilize.

Subscribe to the Kaseya Status Page for updates: https://status.kaseya.com/
Posted Feb 03, 2026 - 18:01 EST

Investigating

We are aware of a problem where Endpoint Backup and Endpoint Backup for PC assets may encounter intermittent backup failures.



The Kaseya R&D Team is currently investigating the issue and working towards a resolution.



Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Feb 03, 2026 - 14:01 EST
This incident affected: Datto / Unitrends Endpoint Backup (Backup) and Datto / Unitrends Endpoint Backup for PCs (Backup, Verification).