ConnectBooster - Live Portals Inaccessible

Incident Report for Kaseya Inc

Postmortem

Summary:
Between 2026-03-25 13:30 UTC and 2026-03-25 14:10 UTC, about 66% of Connect Booster partners were unable to login to their instance(s) or process payments. 

 

Root Cause:  

ConnectBooster attempted to auto-scale and provision new instances of the application to accommodate more load, however these new instances failed to start due to a dependency failure. 

 

Incident Timeline:  

  • Identified: 2026-03-25T13:46 UTC  

  • Resolved: 2026-03-25T14:10 UTC  

 

Preventative Measures:
To reduce the likelihood and impact of similar incidents in the future, we are taking the following steps:  

  • Improving our independent monitoring systems to ensure these failures are caught and remediated more quickly. 

  • Modifying startup dependency requirements to be less stringent. In the future, in the event of a failure in certain parts of the product or in the event of certain external vendor failures, unaffected parts of the product will continue to function.

Posted Mar 27, 2026 - 13:23 EDT

Resolved

Starting at 9:30 AM Eastern time, ConnectBooster Live Portals were inaccessible. Users could not log in and customers were not able to make payments.

The Kaseya R&D Team resolved the issue at 10:10 AM Eastern time. All users should now be able to access their Live portals as expected.

Subscribe to this Kaseya Status Page to be notified when an RCA is posted.
Posted Mar 25, 2026 - 09:30 EDT