Partial Service Disruption - UniView, Passly

Incident Report for Kaseya Inc

Update

We are continuing to work on a fix for this issue.
Posted Dec 02, 2025 - 04:06 EST

Identified

We are aware of an issue where Uniview and Passly users are not receiving email notifications.

Our team is actively working to restore the services.

We apologize for the inconvenience caused.

- Cloud Operations Team
Posted Dec 01, 2025 - 21:55 EST
This incident affects: Passly (EU, US) and Uniview Unified Backup Portal.