Service Disruption - US - NA1VSA04

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Jan 09, 2026 - 12:08 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 09, 2026 - 08:39 EST

Update

We are continuing to investigate this issue.
Posted Jan 09, 2026 - 06:30 EST

Investigating

We are currently experiencing service disruption for US - NA1VSA04, where administrators may be unable to login to UI.

Our team is actively working to restore functionality at this time.

We apologize for any inconvenience.

- Cloud Operations Team
Posted Jan 09, 2026 - 01:59 EST
This incident affected: VSA 9 (US - NA1VSA04).