Uniview - Uniview homepage and assets not currently loading

Incident Report for Kaseya Inc

Update

After monitoring the deployed fix, the Kaseya R&D team has observed that Uniview performance has returned to normal and is now reliably loading assets again.

We believe this issue to be resolved but will continue monitoring over the weekend to ensure resolution.
Posted Jul 03, 2026 - 14:34 EDT

Update

We are continuing to monitor for any further issues.
Posted Jul 03, 2026 - 13:29 EDT

Monitoring

The Kaseya R&D team has found the problem and deployed a fix.

They are closely monitoring the situation to confirm resolution.
Posted Jul 03, 2026 - 13:29 EDT

Investigating

We are currently aware of a problem where Uniview is not loading assets for some customers.

The Kaseya R&D Team is actively investigating.

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Jul 03, 2026 - 13:06 EDT
This incident affects: Uniview Unified Backup Portal.