Germany Data Center Infrastructure - Service Performance Degradation Impacting Offsite Capabilities.

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Aug 25, 2026 - 12:34 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 25, 2026 - 12:05 EDT

Update

We are continuing to work on a fix for this issue.
Posted Aug 24, 2026 - 13:15 EDT

Identified

We are aware of a problem where customers in the Germany region using Datto BCDR, Datto SaaS Protection, and Datto Endpoint Backup are currently experiencing service degradation affecting offsite performance and related operations.


The Kaseya Engineering Team has identified the issue and is working towards a resolution.


Should you need any additional questions or require assistance, please contact our support team at https://helpdesk.kaseya.com/hc/en-gb#/contact


Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Aug 24, 2026 - 11:46 EDT
This incident affected: Datto / Unitrends Endpoint Backup (Agent Registration, Backup), Datto SaaS Protection (SaaS Protection Backups, SaaS Protection Console Login, SaaS Protection Seat Management, SaaS Protection Restores/Exports), Datto / Unitrends Endpoint Backup with Disaster Recovery (Backup, Verification, Recovery), Datto / Unitrends Endpoint Backup for PCs (Backup, Verification, Recovery), and Datto BCDR Devices (Off-Site Synchronization, Off-Site Recovery).