Autotask PSA - LR01, UKLR, DE1, EU1, UK01, UK02, UK03, ES01, ES02, AE01, AE02, AE03, AW01, AW02, AW03 - Currency symbol showing for the Total Count in Doughnut Widgets

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Aug 29, 2025 - 04:22 EDT

Identified

We are aware of an issue where currency symbols are appearing on dashboard widgets with the visualisation type set to 'Doughnut'.

Our Engineering teams have identified the cause of the issue and are working towards applying a fix.

Thank you for your patience and understanding.
Posted Aug 28, 2025 - 07:24 EDT
This incident affected: Autotask PSA (Limited Release, America East, America East 2, America East 3, America West, America West 2, America West 3, UK Limited Release (United Kingdom), UK (United Kingdom), UK 2 (United Kingdom), UK03 (United Kingdom), EU1 (English Europe and Asia), Australia / New Zealand, Australia / New Zealand 2, German (Deutsch), Spanish (Español), Report Data Warehouse, AT01).