Datto BCDR - Recovery Launchpad Will Fail To Load For BCDR Users

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Jun 05, 2025 - 11:42 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 05, 2025 - 10:57 EDT

Identified

We are aware of a problem where the Recovery Launchpad will fail to load for BCDR users.



The Kaseya R&D Team has identified the issue and is working towards a resolution.



Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Jun 05, 2025 - 08:31 EDT
This incident affected: Datto / Unitrends Endpoint Backup with Disaster Recovery (Recovery), Datto / Unitrends Endpoint Backup for PCs (Recovery), Datto / Unitrends Backup for Microsoft Azure (Recovery), and Datto BCDR Devices (Off-Site Recovery).