Autotask - Chromium update causing excessive load times for Widgets

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.

Thank you for your patience while we investigated and resolved this behavior.
Posted Apr 10, 2025 - 10:18 EDT

Identified

We are aware of a problem where the newest version of Chromium Browsers, such as Google Chrome and Microsoft Edge, causes some Widgets to display extensive loading times or not render at all.

The Kaseya R&D Team has identified the cause and developed a fix currently being tested.

In the meantime, you can work around this problem by using a different browser.

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Apr 04, 2025 - 15:49 EDT
This incident affected: Autotask PSA (Limited Release, America East, America East 2, America East 3, America West, America West 2, America West 3, UK Limited Release (United Kingdom), UK (United Kingdom), UK 2 (United Kingdom), UK03 (United Kingdom), EU1 (English Europe and Asia), Australia / New Zealand, Australia / New Zealand 2, German (Deutsch), Spanish (Español), Report Data Warehouse, AT01).