Autotask PSA - Inbound Email Processing - Inbound emails are not being processed and related items are not being created

Incident Report for Kaseya Inc

Resolved

The system finished processing the remaining items in the queue, and the Incoming Email Processing is currently creating designated items in real time.

This incident is resolved.
Posted Sep 14, 2026 - 07:57 EDT

Update

The system is currently working through items that queued up during this issue, therefore incoming email processing may still be delayed.
Posted Sep 14, 2026 - 07:23 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 14, 2026 - 06:40 EDT

Identified

We are aware of a problem where the inbound email parser is not creating items in the target Autotask PSA database on the DE1 and EU1 zones.

The Kaseya Engineering Team is working on resolving the issue.

Should you need any additional questions or require assistance, please contact our support team at https://helpdesk.kaseya.com/hc/en-gb#/contact

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Sep 14, 2026 - 05:21 EDT
This incident affected: Autotask PSA (EU1 (English Europe and Asia), German (Deutsch)).