Datto SaaS Protection - Backup performance degradation for some SharePoint/Teams services on pod 'use1-saas-p5'

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Mar 19, 2026 - 09:12 EDT

Update

Backups are processing normally and backup success rates continue to improve.

Our R&D team is continuing to monitor.
Posted Mar 18, 2026 - 10:07 EDT

Monitoring

We are seeing continued improvement in backup performance on pod use1-saas-p5.

The R&D team will continue monitoring the environment until full recovery is confirmed.
Posted Mar 18, 2026 - 08:30 EDT

Identified

We are currently investigating an issue affecting some customers hosted on pod use1-saas-p5, where backup performance degradation has been observed for certain SharePoint services.

The Kaseya R&D team has identified the root cause and is actively working on a resolution. Further updates will be provided as progress is made.
Posted Mar 18, 2026 - 06:49 EDT
This incident affected: Datto SaaS Protection (SaaS Protection Backups).