DattoRMM - Vidal - Users are unable to access the platform.

Incident Report for Kaseya Inc

Resolved

The issue affecting access to the Datto RMM Vidal platform has been resolved.
Posted Sep 01, 2026 - 11:56 EDT

Monitoring

The Kaseya Engineering Team has issued a fix. Service has been restored, and we are monitoring the environment to ensure continued stability.
Posted Sep 01, 2026 - 08:35 EDT

Investigating

We are aware of a problem where users are unable to access the Vidal platform

The Kaseya Engineering Team is actively investigating and we will provide updates as more information becomes available.

Should you need any additional questions or require assistance, please contact our support team at https://helpdesk.kaseya.com/hc/en-gb#/contact

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Sep 01, 2026 - 07:37 EDT
This incident affected: Datto RMM (Vidal (US East)).