Endpoint Backup v2 - Subset of Endpoint Backup v2 assets are experiencing slow or incomplete backups due to 504 Gateway Timeout errors.

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Jul 17, 2026 - 14:05 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 17, 2026 - 11:58 EDT

Investigating

We are aware of a problem where Endpoint Backup v2 assets can experience slow or failed backups due to a "504 Gateway Timeout" error.


The Kaseya R&D Team is currently investigating the issue and working towards a resolution.


Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Jul 16, 2026 - 09:59 EDT
This incident affected: Endpoint Backup V2 (Backup).