Datto RMM - Merlot - Activity Log failing to load results in the UI

Incident Report for Kaseya Inc

Postmortem

On 27th June 2025 at 10:50 AM our teams have been alerted that partners on the Merlot platform are experiencing a service issue which caused Device Activity Card details and the Activity Log on the Web UI to stop displaying data only showing “None Found” instead.

The root cause for this service issue was traced to the configuration of the service handling the processing of logged activities which led to a bottleneck resulting in increased completion times when the Web UI requested data from the service. When these requests exceeded the timeout threshold, the UI defaulted to displaying "None Found".

The infrastructure team adjusted the configuration restoring the service back to a healthy state. Normal functionality was fully restored by 2:10 PM on the same day.

Posted Jul 02, 2025 - 09:33 EDT

Resolved

This incident has been resolved.
Posted Jun 27, 2025 - 11:25 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 27, 2025 - 09:13 EDT

Investigating

We are aware of a problem where the device-level activities card, and global activity log are failing to load results in the UI on Datto RMM on Merlot.

The Kaseya R&D Team currently investigating.

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Jun 27, 2025 - 06:01 EDT
This incident affected: Datto RMM (Merlot (EU2)).