Datto RMM - Pinotage (EU1) - Sporadically reported internal server errors when navigating the product

Incident Report for Kaseya Inc

Postmortem

On 28th March 2025 at 10:14am UTC, some Datto RMM partners on the Pinotage platform experienced a service incident that caused users to receive internal server errors when logging in or navigating the product, or when attempting to start a Web Remote session to an endpoint.

The root cause of the incident was identified to be caused by higher than usual platform utilization. The platform was automatically scaled, however, the configured limit was reached.

The limit was manually adjusted by the R&D team to resolve the issue, and this increased limit was made permanent in order to ensure that similar utilization does not cause issues in the future.

Measures are being put in place to alert the R&D team when proactive scaling is necessary to meet increased usage demand in the future.

Posted Apr 01, 2025 - 04:47 EDT

Resolved

This incident has been resolved.
Posted Mar 28, 2025 - 09:46 EDT

Monitoring

The Kaseya R&D team took action to resolve issues with navigating the product on the Pinotage platform.

We are currently closely monitoring the health of the service.

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Mar 28, 2025 - 06:46 EDT
This incident affected: Datto RMM (Pinotage (EU1)).