We are continuing to monitor for any further issues.
Posted Apr 10, 2026 - 04:39 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 10, 2026 - 04:38 EDT
Update
We are experiencing issues with remote control on all VSA10 regions randomly, that may be resulting in impacting administrators ability to manage endpoints. Our team is working to restore functionality on the instance at this time.
We apologize for any disruption this may cause.
- Kaseya Cloud Operations Team
Posted Apr 10, 2026 - 02:20 EDT
Investigating
We are experiencing issues with remote control on APAC VSA10 that may be resulting in impacting administrators ability to manage endpoints. Our team is working to restore functionality on the instance at this time.
We apologize for any disruption this may cause.
- Kaseya Cloud Operations Team
Posted Apr 09, 2026 - 23:46 EDT
This incident affected: VSA 10 (APAC, EU, US, APAC-Hosted-1, US - Remote Control, EU - Remote Control, APAC - Remote Control).