Datto Portal - Users Cannot Access downloads.datto.com in the APAC Region

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 22:49 EDT

Investigating

We're aware of an issue where the downloads.datto.com page is currently unreachable in the APAC region.

We are actively investigating the issue.

Subscribe to the Kaseya Status Page for up-to-date information: https://status.kaseya.com/
Posted Jun 12, 2025 - 20:02 EDT
This incident affected: download.kaseya.com (https://download.kaseya.com).