Please be informed that a major maintenance update is planned for the upcoming weekend (1/18/2025-1/19/2025). During this time, certain nodes will be temporarily taken offline, which will impact backup and restore operations. If you experience errors over the weekend, please attribute these issues to the ongoing maintenance.
Should any errors persist beyond the maintenance window, we encourage you to contact our technical support team for further assistance.
Posted Jan 17, 2025 - 14:25 EST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 07, 2025 - 16:00 EST
Scheduled
We will be performing a routine maintenance to the Datto Endpoint Backup v2 product on 1/7/2025 starting at 9:00PM UTC until 1/21/2025 9:00PM UTC.
During this window, certain assets may experience delays in backup completion.
Subscribe to receive up-to-date notifications on future maintenance periods by visiting https://status.kaseya.com/