Datto RMM / Datto EDR - Partners utilizing Datto RMM integrated with Datto EDR may have the RMM Sync location reset to the Default Location which can lead to the agent checking into the default location

Incident Report for Kaseya Inc

Postmortem

Starting on August 13th through August 17th, Datto EDR released an update using our standard phased rollout across customer instances.  One of the changes in the release was the way Datto EDR synchronized Datto RMM Sites.  

It was discovered that under a specific scenario, Datto EDR would not be able to resolve the Datto RMM Site and would move the Datto EDR endpoint to the “Default” Site.  The policies on the “Default” Site may differ from what the customer intended.

Specifically, this could occur if Datto EDR is integrated with Datto RMM and the Datto RMM agent did not have a registry key related to the Datto RMM Site is was associated with.

The fix has been deployed and will check both the registry and file system on each endpoint to find the Datto RMM Site – no user action is required, Datto EDR endpoints will automatically sync to the correct Site.

Posted Sep 03, 2024 - 09:12 EDT

Resolved

All EDR tenants have been updated. This incident has been resolved.
Posted Aug 22, 2024 - 11:40 EDT

Monitoring

The fix has gone through QA testing and is scheduled for release tonight. Datto EDR leverages a staggered release process. You'll receive an in-product notification when the latest updates are available to your instance. We will continue to monitor the release to ensure the issue is resolved.
Posted Aug 21, 2024 - 16:56 EDT

Identified

The issue has been identified. A fix has been developed and is currently undergoing QA testing
Posted Aug 19, 2024 - 13:15 EDT

Investigating

We are aware of a problem where partners utilizing Datto RMM integrated with Datto EDR may have the RMM Sync location reset to the Default Location which can lead to the agent checking into the default location

The Kaseya R&D Team has been made aware of the problem and is actively working on a resolution.

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Aug 19, 2024 - 11:06 EDT
This incident affected: Datto EDR (Agent Connection, Detection Engine, Notification Engine, Reporting Engine).